$re = '/^[a-z\d]([a-z\d\-]{0,61}[a-z\d])?(\.\b(domain.com)\b)/m';
$str = 'user1.domain.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);