$re = '/(?:\G(?!\A),|\()\K[^,]+(?=[^()]*\))/m';
$str = '"some t3xt../s8fo=123,sij(variable1=123,variable2=743,variable3=535)"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);