re = /-[\d\.]+/m
str = ' -59.99 -46.54 -25.59 -25.09 -25.51 -48.25 -48.06 -48.06 -48.34 -47.07'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end