#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\??(_[a-z]+){2,}(>[a-z]+)?$"
Local $sString = "_cosa_cosa_cosa>cosa" & @CRLF & _
"cosa" & @CRLF & _
"?cosa" & @CRLF & _
"?_cosa_cosa" & @CRLF & _
"_cosa_cosa" & @CRLF & _
"cosa_" & @CRLF & _
"_cosa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")