re = /^ *(?:@\w{1,15} *)+(?:ligne|bus|tram)? *(?<line>[a-zA-Z0-9][0-9]?)\b[\s\?]*$/i
str = '@Tag_Grenoble LIGNE C4 ???????'
# Print the match result
str.match(re) do |match|
puts match.to_s
end