$re = '/ \K\S+=["\']?[^>"\']+["\']?>??/s';
$str = '<anytag aa="att1">DESC 1</anytag>
<item aa="att2">DESC 2</item>
<anytag bb="att3">DESC 3</anytag>
<anytag alt=att4>DESC 4</anytag>
<anytag src="att5">DESC 5</anytag>
<anytag src="att6">DESC 6</anytag>
<anytag src=\'att7\'>DESC 7</anytag>
<anytag src=\'att8\'>DESC 8</anytag>
<anytag href="att9" title="title1">DESC 9</anytag>
<anytag blabla="att10">DESC 10</anytag>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);