$re = '/(?<=(?<!xx)34)56(?=78)/m';
$str = '12345678
xx345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);