# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<ROW(?=((?!ROW).)*<FROM>\d*412\d*<\/FROM>).*?</ROW>"
test_str = ("<ROW num=\"381\">\n"
" <TO>8549672167</TO>\n"
" <FROM>14121</FROM>\n"
" <TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>\n"
"</ROW>\n"
"<ROW num=\"382\">\n"
" <TO>8549674167</TO>\n"
" <FROM>224111</FROM>\n"
" <TIME>5/10/2009 19:49:37</TIME>\n"
" <TEXT>Hme</TEXT>\n"
"</ROW>\n"
"<ROW num=\"381\">\n"
" <TO>854967216741</TO>\n"
" <FROM>893674258412</FROM>\n"
" <TIME>5/10/2009 19:49:3</TIME><TEXT>Blah Blah Blah</TEXT>\n"
"</ROW>\n\n"
"fasdf412")
matches = re.finditer(regex, test_str, re.MULTILINE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.