import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http\\:|ftp\\:|https\\:)?(\\/\\/)?([\\w_-]+(?:(?:\\.[\\w_-]+)+)[\\w.,@?^=%&:\\/~+#-()].*[\\w@?^=%&\\/~+#-]?)(?=\\s|$)";
final String string = "https://en.wikipedia.org/wiki/Salt_(2010_film)\n"
+ "https://en.wikipedia.org/wiki/Salt_2010_film\n"
+ "https://en.wikipedia.org/wiki/Salt-2010-film\n"
+ "HTTPS://en.wikipedia.org/wiki/Salt-2010-film\n"
+ "//en.wikipedia.org/wiki/Salt_2010_film\n"
+ "https://en.wikipedia.org/wiki/Salt_2010_film?cat=1\n"
+ "https://en.wikipedia.org/wiki/Salt_2010_film#anchor\n"
+ "https://en.wikipedia.org/wiki/Salt_(2010_film)?cat=2\n"
+ "This is a sentence that has a link in it. https://en.wikipedia.org/wiki/Salt_(2010_film)?cat=3 This regex allows me to create an HTML anchor tag around it.";
final String subst = "<a href=\"${1}${2}${3}\" target=\"_blank\">${1}${2}${3}</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}