$re = '/_(?=[abc])a?b?c?_/m';
$str = '_a_
_b_
_ac_
_abc_
_ba_
_ca_
__';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);