re = /^(?!$)[a-zA-Z,.!? ]*(?:\d[a-zA-Z,.!? ]*){0,3}$/m
str = 'Hello 1234
Hello 123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end