re = /(?<=Size: ).*?(?=")/m
str = '"Colour: Black
Size: L"
"Colour: Black
Size: XS"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end