#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sm)([A-Z][a-z]{2} [A-Z][a-z]{2} \d{2} \d{2}:\d{2}:\d{2} CET \d{4})\n(/dev.*?) ==> (.*?)\n.*?\n(\d*) bytes .*? copied, (.*?) s, (.*?) (.*?s\n)(.*?)Exit status: (\d*)\n"
Local $sString = "Thu Feb 11 15:01:37 CET 2021" & @CRLF & _
"/dev/mapper/vgdata-euramis_u000 ==> /ec/prod/server/euramis/u000" & @CRLF & _
"1+0 records in" & @CRLF & _
"1+0 records out" & @CRLF & _
"512 bytes (512 B) copied, 0.00383015 s, 134 kB/s" & @CRLF & _
" Command being timed: "dd if=/dev/zero of=/ec/prod/server/euramis/u000/TstPerf/test_512_1 bs=512 count=1 oflag=dsync"" & @CRLF & _
" User time (seconds): 0.00" & @CRLF & _
" System time (seconds): 0.00" & @CRLF & _
" Percent of CPU this job got: 25%" & @CRLF & _
" Elapsed (wall clock) time (h:mm:ss or m:ss): 0:00.00" & @CRLF & _
" Average shared text size (kbytes): 0" & @CRLF & _
" Average unshared data size (kbytes): 0" & @CRLF & _
" Average stack size (kbytes): 0" & @CRLF & _
" Average total size (kbytes): 0" & @CRLF & _
" Maximum resident set size (kbytes): 812" & @CRLF & _
" Average resident set size (kbytes): 0" & @CRLF & _
" Major (requiring I/O) page faults: 0" & @CRLF & _
" Minor (reclaiming a frame) page faults: 252" & @CRLF & _
" Voluntary context switches: 4" & @CRLF & _
" Involuntary context switches: 1" & @CRLF & _
" Swaps: 0" & @CRLF & _
" File system inputs: 0" & @CRLF & _
" File system outputs: 8" & @CRLF & _
" Socket messages sent: 0" & @CRLF & _
" Socket messages received: 0" & @CRLF & _
" Signals delivered: 0" & @CRLF & _
" Page size (bytes): 4096" & @CRLF & _
" Exit status: 0" & @CRLF & _
"Thu Feb 11 16:02:17 CET 2021" & @CRLF & _
"/dev/mapper/vgdata-euramis_u000 ==> /ec/prod/server/euramis/u000" & @CRLF & _
"1+0 records in" & @CRLF & _
"1+0 records out" & @CRLF & _
"512 bytes (512 B) copied, 0.00275458 s, 186 kB/s" & @CRLF & _
" Command being timed: "dd if=/dev/zero of=/ec/prod/server/euramis/u000/TstPerf/test_512_1 bs=512 count=1 oflag=dsync"" & @CRLF & _
" User time (seconds): 0.00" & @CRLF & _
" System time (seconds): 0.00" & @CRLF & _
" Percent of CPU this job got: 33%" & @CRLF & _
" Elapsed (wall clock) time (h:mm:ss or m:ss): 0:00.00" & @CRLF & _
" Average shared text size (kbytes): 0" & @CRLF & _
" Average unshared data size (kbytes): 0" & @CRLF & _
" Average stack size (kbytes): 0" & @CRLF & _
" Average total size (kbytes): 0" & @CRLF & _
" Maximum resident set size (kbytes): 816" & @CRLF & _
" Average resident set size (kbytes): 0" & @CRLF & _
" Major (requiring I/O) page faults: 0" & @CRLF & _
" Minor (reclaiming a frame) page faults: 253" & @CRLF & _
" Voluntary context switches: 4" & @CRLF & _
" Involuntary context switches: 1" & @CRLF & _
" Swaps: 0" & @CRLF & _
" File system inputs: 0" & @CRLF & _
" File system outputs: 8" & @CRLF & _
" Socket messages sent: 0" & @CRLF & _
" Socket messages received: 0" & @CRLF & _
" Signals delivered: 0" & @CRLF & _
" Page size (bytes): 4096" & @CRLF & _
" Exit status: 0" & @CRLF & _
"Thu Feb 11 17:02:26 CET 2021" & @CRLF & _
"/dev/mapper/vgdata-euramis_u000 ==> /ec/prod/server/euramis/u000" & @CRLF & _
"1+0 records in" & @CRLF & _
"1+0 records out" & @CRLF & _
"512 bytes (512 B) copied, 0.00323523 s, 158 kB/s" & @CRLF & _
" Command being timed: "dd if=/dev/zero of=/ec/prod/server/euramis/u000/TstPerf/test_512_1 bs=512 count=1 oflag=dsync"" & @CRLF & _
" User time (seconds): 0.00" & @CRLF & _
" System time (seconds): 0.00" & @CRLF & _
" Percent of CPU this job got: 25%" & @CRLF & _
" Elapsed (wall clock) time (h:mm:ss or m:ss): 0:00.00" & @CRLF & _
" Average shared text size (kbytes): 0" & @CRLF & _
" Average unshared data size (kbytes): 0" & @CRLF & _
" Average stack size (kbytes): 0" & @CRLF & _
" Average total size (kbytes): 0" & @CRLF & _
" Maximum resident set size (kbytes): 820" & @CRLF & _
" Average resident set size (kbytes): 0" & @CRLF & _
" Major (requiring I/O) page faults: 0" & @CRLF & _
" Minor (reclaiming a frame) page faults: 252" & @CRLF & _
" Voluntary context switches: 4" & @CRLF & _
" Involuntary context switches: 1" & @CRLF & _
" Swaps: 0" & @CRLF & _
" File system inputs: 0" & @CRLF & _
" File system outputs: 8" & @CRLF & _
" Socket messages sent: 0" & @CRLF & _
" Socket messages received: 0" & @CRLF & _
" Signals delivered: 0" & @CRLF & _
" Page size (bytes): 4096" & @CRLF & _
" Exit status: 0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")