package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ma+n`)
var str = `mn
man
maaan
main
woman`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}