re = /^[0-9A-HJ-NPQRTUWXY]{2}\d{6}[0-9A-HJ-NPQRTUWXY]{10}$/
str = 'http://localhost:1111'
# Print the match result
str.match(re) do |match|
puts match.to_s
end