$re = '/^(?!\d+$)\w+$/m';
$str = 'expression123
123expression
exp123ression
1235234567544';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);