$re = '/\b(?<!-)\d+/m';
$str = '125 -898 8969 4788 -2 158 -947 599';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);