$re = '/(?:https?):\/\/[\w-\.@#\/%?=~|!:,.;]*(?:&(?!lt)[\w=%]*)?/m';
$str = 'https://a.com?a=b&c=d
https://a.com<';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);