package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Ab\(123\)`)
var str = `A 123
B 456
Ab(123)
......`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}