import re
regex = re.compile(r"\.\w{3}\.")
test_str = ("Test.jpg.tif\n"
"hilfe.opg.jpg\n\n")
subst = "."
result = regex.sub(subst, test_str)
if result:
print(result)