package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)http(s)?(\s+)`)
var str = ` because she s the worst
i am referring to this http iimgurcom5srylmijpg does it have any deeper meaning or does it signify anything i just do nt get it why she d do that
cheating but zoldycks must have a great time at thanksgiving
kurosaki ichigo http images5fanpopcomimagephotos29000000ichigowallpaperkurosakiichigo290694271024768jpg and kurosaki mea http staticzerochannetkurosakimeafull1689483jpg
there are a shit ton of koutarous but the presence of one https smediacacheak0pinimgcomoriginals1219ed1219ed717fc2bfce372759bba2fe1cfegif is enough to make it the most interesting party.`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}