$re = '/CL\d+__([a-zA-Z0-9_]+?)__/m';
$str = '20260317_104524__CL2418942__SOC_PM_DF_CSTATE_REGR__df_cstate_regr__df_umc_nbio_hubs_pcie_msub_\\_.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);