import re
regex = re.compile(r"(?:\bT\s(\w+<T>)\(.*\);|(\w+[<?\w+>?]*\s)(\w+)\b((\s{[get;\|private get;|set;]+)|\(.*\));)", flags=re.MULTILINE)
test_str = ("void Something();\n"
"int SomethingElse(Parameter parameter);\n"
"List<Something> SomethingVeryElse(One one, Two two);\n"
"T Get<T>(params object[] args);\n"
"IEnumerable<Plugin> Plugins { get; }")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")