$re = '/((?:Stranger|You):\s+)((?:(?!(?:Stranger|You):\s).)*)/m';
$str = 'foofoofoofoofoofooStranger: heyy You: asdasdasdassdasad Stranger: asdasdasd You: Stranger:asdasdasd You: bye You have disconnected.
\\x0c
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);