$re = '`^/rootfolder(?:(.*?)/magicword)?.*$`m';
$str = '/rootfolder/test/a/b/c/magicword/blabla
/rootfolder/test/a/b/c';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);