package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^((?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))(?:[,-](?1)){0,49}$`)
var str = `10.10.10.1,127.0.0.1-127.0.0.125`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}