import re
regex = re.compile(r"\w*Latitude:(-?\d+(?:\.\d+)?)\w*Longitude:(-?\d+(?:\.\d+)?)", flags=re.MULTILINE)
test_str = ("WorkLocationBoundingBox\n"
"Latitude:30.556555Longitude:-97.659824\n"
"SecondLatitude:30.569138SecondLongitude:-97.650855")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")