$re = '/[1-9]\d+|[89]/';
$str = '1
2
3
4
5
6
7
8
9
10
11
12
15
20
42
77
123
764321
3593535
082';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);