re = /((?!abc).)*/m
str = 'abXYabcXYZ
abXYabcXYZabXYabcXYZ
abXYabcXYZabXYabcXYZabXYabcXYZabXYabcXYZabXYabcXYZabXYabcXYZ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end