import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([ \\n]*?(select[ \\n]*?max\\([ \\n].*?column_name[ \\n]\\)[\\D\\d \\n]+)[ \\n]*?\\)";
final String string = "value = ( select max( tbl.column_name ) from table tbl where trim(colum2)='value1'\n"
+ "and (trim((colum3)))='value3')\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}