const regex = /DIA\s+(\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('DIA\\s+(\\S+)', 'g')
const str = `Showing first 10 out of 413 items. Use the filters below to find additional items.Search:StateCountryAllAfghanistanAland IslandsAlbaniaAlgeriaAmerican SamoaAndorraAngolaAnguillaAntarcticaAntigua and BarbudaArgentinaArmeniaArubaAustraliaAustriaAzerbaijanBahamasBahrainBangladeshBarbadosBelarusBelgiumBelizeBeninBermudaBhutanPlurinational State of BoliviaBonaire, Sint Eustatius and SabaBosnia and HerzegovinaBotswanaBouvet IslandBrazilBritish Indian Ocean TerritoryBrunei DarussalamBulgariaBurkina FasoBurundiCambodiaCameroonCape VerdeCayman IslandsCentral African RepublicChadChileChinaChristmas IslandCocos (Keeling) IslandsColombiaComorosCongoThe Democratic Republic of the CongoCook IslandsCosta RicaCote d'IvoireCroatiaCubaCuracaoCyprusCzech RepublicDenmarkDjiboutiDominicaDominican RepublicEcuadorEgyptEl SalvadorEquatorial GuineaEritreaEstoniaEthiopiaFalkland Islands (Malvinas)Faroe IslandsFijiFinlandFranceFrench GuianaFrench PolynesiaFrench Southern TerritoriesGabonGambiaGeorgiaGermanyGhanaGibraltarGreeceGreenlandGrenadaGuadeloupeGuamGuatemalaGuernseyGuineaGuinea-BissauGuyanaHaitiHeard Island and McDonald IslandsHoly See (Vatican City State)HondurasHong KongHungaryIcelandIndiaIndonesiaIslamic Republic of IranIraqIrelandIsle of ManIsraelItalyJamaicaJapanJerseyJordanKazakhstanKenyaKiribatiDemocratic People's Republic of KoreaRepublic of KoreaKuwaitKyrgyzstanLao People's Democratic RepublicLatviaLebanonLesothoLiberiaLibyan Arab JamahiriyaLiechtensteinLithuaniaLuxembourgMacaoThe Former Yugoslav Republic of MacedoniaMadagascarMalawiMalaysiaMaldivesMaliMaltaMarshall IslandsMartiniqueMauritaniaMauritiusMayotteMexicoFederated States of MicronesiaRepublic of MoldovaMonacoMongoliaMontenegroMontserratMoroccoMozambiqueMyanmarNamibiaNauruNepalNetherlandsNew CaledoniaNew ZealandNicaraguaNigerNigeriaNiueNorfolk IslandNorthern Mariana IslandsNorwayOccupied Palestinian TerritoryOmanPakistanPalauPanamaPapua New GuineaParaguayPeruPhilippinesPitcairnPolandPortugalPuerto RicoQatarReunionRomaniaRussian FederationRwandaSaint BarthelemySaint Helena, Ascension and Tristan da CunhaSaint Kitts and NevisSaint LuciaSaint Martin (French part)Saint Pierre and MiquelonSaint Vincent and The GrenadinesSamoaSan MarinoSao Tome and PrincipeSaudi ArabiaSenegalSerbiaSeychellesSierra LeoneSingaporeSint Maarten (Dutch part)SlovakiaSloveniaSolomon IslandsSomaliaSouth AfricaSouth Georgia and the South Sandwich IslandsSouth SudanSpainSri LankaSudanSurinameSvalbard and Jan MayenSwazilandSwedenSwitzerlandSyrian Arab RepublicTaiwan, Province of ChinaTajikistanThailandTimor-LesteTogoTokelauTongaTrinidad and TobagoTunisiaTurkeyTurkmenistanTurks and Caicos IslandsTuvaluUgandaUkraineUnited Arab EmiratesUnited KingdomUnited Republic of TanzaniaUnited States/United States Territories/CanadaUruguayUzbekistanVanuatuBolivarian Republic of VenezuelaViet NamBritish Virgin IslandsWallis and FutunaWestern SaharaYemenZambiaZimbabweSorted by Product/Service IDSorted by
Service TypeSorted by Service NameSorted by Service AddressSorted by CitySorted by StateSorted by Circuit ID
Show10 25 100 250 413
1 - 10 of 413
Service Type Product/Service ID Service Name Service Address City State Circuit ID DIA 8778680044 SVU-RMW ANNISTON SERF1450 COMMERCE BLVD ANNISTONALDIA DS1IT-15600804-123 SVU-RMW ANNISTON2130 ROBERTS DR ANNISTONALDIA DS1IT15598059 SVU-RNO BILLINGS1629 W KING AVE W BILLINGSMTDIA DS1IT-1483-5539-ABC SVU-ACI BELTSVILLE MD 212050 BALTIMORE AVE BELTSVILLEMDDIA DS1IT-1426-8602 SVU-JEWL/OSCO #48500 T1 LAB150 E PIERCE RD FLR 1 RM TELCO ITASCAILDIA SVUSOCAL6767IA SVU-EP INTERNET PAYMNT CIRCUIT11840 VALLEY VIEW RD BLDG MAIN FLR 1 RM TELCO EDEN PRAIRIEMNDIA ITORN07-12921789.03 SVU-MICROTRAX TUSTIN CA14452 FRANKLIN AVE FLR 1 TUSTINCADIA 69/KXFS/000703//ACSO SVU-SNR-BLAKE ROAD COLD STORAGE325 BLAKE RD N BLDG MAIN FLR 1 RM TELCO HOPKINSMNDIA 0318SUPV6522PI01243 SVU-ANR-BIG SKY OFFICE MT1414 3RD ST NW GREAT FALLSMTDIA DS1IT-13319768 ALBERTSONS250 E PARKCENTER BLVD BOISEID
1 - 10 of 413`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}