re = /(?:^|[(\s[])(\d+(?:[.,]0+(?!\d))?)(?=[]\s)]|$)/m
str = '2 2.0
Test (2.00001) Test (2.000) Test 2.1 Test (2,0001) Test 2,000 Test 2,1000 test 2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end