import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\.\\d+\\.\\d+(\\-[a-zA-z0-9\\-]+(\\.[a-zA-z0-9\\-]+)*)?(\\+[a-zA-z0-9\\-]+(\\.[a-zA-z0-9\\-]+)?)?$";
final String string = "0.0.2-post.41+1.5ccabe4.dirty";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}