$re = '~(?<=^..).~m';
$str = 'ABCDEF => C
123456 => 3
A B C';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);