package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.*code=09141714625, request={([^}]*)}`)
var str = `[2020-04-09 11:17:17.869 ][correlation=2b3, code=09141714625, request={ id='gei1i1ds-1d4a', event='new', version='1'....}, response={myResponse='ok'} registered='YES']
[2020-04-09 11:17:18.484] Lorem Ipsum is simply dummy text of the printing and typesetting industry. Lorem Ipsum has been the industry's standard dummy text ever since the 1500s, when an unknown printer took a galley of type and scrambled it to make a type specimen book. There are many variations of passages of Lorem Ipsum available, but the majority have suffered alteration in some form, by injected humour, or randomised words which don't look even slightly believable. If you are going to use a passage of Lorem Ipsum, you need to be sure there isn't anything embarrassing hidden in the middle of text. All the Lorem Ipsum generators on the Internet tend to repeat predefined chunks as necessary, making this the first true generator on the Internet. It uses a dictionary of over 200 Latin words, combined with a handful of model sentence structures, to generate Lorem Ipsum which looks reasonable.
[2020-04-09 11:17:17.869 ][2020-04-09 11:17:17.869 ][correlation=2b3, code=09141714625, request={ id='gei1i1ds-1d4a', dbSattus='registered', version='1'....}, fail={NO} registered='YES']`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}