package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\/hub\/([0-9a-zA-Z-]*)(\/.*)?`)
var str = `/hub/xxx/test
/hub/xxx
/hub/xxx/abc/123/24
/hub/e0598b42-a9b0-4214-8533-4c031975348e/test/potato/?wor`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}