$re = '/^(Mon(?:day)?)[.,]?$/m';
$str = 'Monday.
Mon
Mon,
Mon.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);