$re = '/[^\[]\w+\)(?!\])/';
$str = '<table
[box]="teamsTypes"
[(bananInBox)]="bananInBox"
(banan)="createDialog()"
class="class"
mat-table
>
</table>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);