import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.{1,80}\\S)(?:[\\r\\n\\f\\v ]+|$)";
final String string = "--- 0---|--- 10---|--- 20---|--- 30---|--- 40---|--- 50---|--- 60---|--- 70---|--- 80---|--- 90---|\n"
+ "123456789|123456789|123456789|123456789|123456789|123456789|1 23456789|123456789|123456789|123456789|\n\n\n"
+ "SELECT\n"
+ " tbl_Hex.Hex_ID\n"
+ " ,tbl_Generic_Tool.Generic_Code AS [Generic Code]\n"
+ " ,tbl_ref_Generic_Type.Generic_Type AS [Generic Type]\n"
+ "FROM tbl_ref_Location\n"
+ " RIGHT JOIN ((tbl_ref_Generic_Type\n"
+ " INNER JOIN tbl_Generic_Tool ON tbl_ref_Generic_Type.Generic_Type_ID = tbl_Generic_Tool.Generic_Type_ID)\n"
+ " INNER JOIN (tbl_ref_Building\n"
+ " INNER JOIN tbl_Hex ON tbl_ref_Building.Building_ID = tbl_Hex.Building_ID) ON tbl_Generic_Tool.Generic_ID = tbl_Hex.Generic_ID) ON tbl_ref_Location.Location_ID = tbl_Hex.Location_ID\n"
+ "GROUP BY\n"
+ " tbl_Hex.Hex_ID\n"
+ " ,tbl_Hex.Hex_No\n"
+ " ,tbl_ref_Building.Building_Abbrev\n"
+ " ,tbl_ref_Location.Location\n"
+ " ,tbl_Generic_Tool.Generic_Code\n"
+ " ,tbl_ref_Generic_Type.Generic_Type\n"
+ "ORDER BY\n"
+ " tbl_Hex.Hex_No;\n";
final String subst = "$1\\r\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}