import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<first><<<<<<< HEAD\\n.*?)(?<========)|(?<second>(?=>>>>>>>).*?\\n)";
final String string = "<<<<<<< HEAD\n"
+ "import { readdir } from \"fs\";\n"
+ "import { createServer } from \"../src/server.js\";\n"
+ "import Jasmine from 'jasmine';\n"
+ "import dotenv from 'dotenv';\n\n"
+ "const jasmine = new Jasmine();\n"
+ "=======\n"
+ "import { start } from \"../src/index.js\";\n\n"
+ "import dotenv from 'dotenv';\n"
+ "import { readdir } from \"fs\";\n"
+ "import Jasmine from 'jasmine';\n"
+ "import { resolve } from 'path';\n\n"
+ ">>>>>>> c80322f... Refactor codebase. Removed ml parts into separate project.\n"
+ "// jasmine.loadConfigFile(`tests/jasmine.json`);\n\n"
+ "const importTests = () => {\n"
+ " return new Promise((resolve, reject) => {\n"
+ " readdir(`./tests`, (err, files) => {\n"
+ " if (err) {\n"
+ " reject(err);\n"
+ " }\n"
+ " files = files.filter(file => { \n"
+ " return file.includes(`test.js`);\n"
+ " });\n"
+ " console.log(files);\n"
+ " files = files.map(file => { \n"
+ " const relativePath = `./${file}`;\n"
+ " return import(relativePath)\n"
+ " .catch(error => {\n"
+ " console.error(`** Error loading ` + relativePath + `: `);\n"
+ " console.error(error);\n"
+ " process.exit(1);\n"
+ " });\n"
+ " });\n\n"
+ " resolve(Promise.all(files));\n"
+ " });\n"
+ " });\n"
+ "};\n\n"
+ "const runTests = () => {\n"
+ "<<<<<<< HEAD\n"
+ " dotenv.config();\n\n"
+ " importTests().then(() => {\n"
+ " const server = createServer({\n"
+ " useAuth: false,\n"
+ " });\n\n"
+ " server.options.port = 4040;\n"
+ " process.env.GRAPHQL_ENDPOINT = `http://127.0.0.1:4040`;\n\n"
+ " server.start(() => {\n"
+ " console.log(`Test server is running on 127.0.0.1:${server.options.port}`);\n"
+ " jasmine.execute();\n"
+ " });\n"
+ "=======\n"
+ " const jasmine = new Jasmine();\n"
+ " const environment = process.env.NODE_ENV || `staging`;\n\n"
+ " dotenv.config({\n"
+ " path: resolve(`../src/config/${environment}/.env`),\n"
+ " });\n\n"
+ " importTests().then(async () => {\n"
+ " process.env.MONGODB_URIS = `mongodb+srv://f4a-shared-t95ry.gcp.mongodb.net/test`;\n"
+ " process.env.GRAPHQL_ENDPOINT = `http://127.0.0.1:4040`;\n"
+ " process.env.PORT = `4040`;\n"
+ " await start();\n"
+ " console.log(`Test server is running on 127.0.0.1:${server.port}`);\n"
+ " jasmine.execute();\n"
+ ">>>>>>> c80322f... Refactor codebase. Removed ml parts into separate project.\n"
+ " });\n"
+ "};\n"
+ "runTests();";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}