#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xs)# Clipping Rectangle" & @CRLF & _
"(?<x>\b[-0-9\.]+\b)(\s)" & @CRLF & _
"(?<y>\b[-0-9\.]+\b)(\s)" & @CRLF & _
"(?<width>\b[-0-9\.]+\b)(\s)" & @CRLF & _
"(?<height>\b[-0-9\.]+\b)(\s)" & @CRLF & _
"(re\nW)" & @CRLF & _
"" & @CRLF & _
"(.*?)" & @CRLF & _
"" & @CRLF & _
"# Text" & @CRLF & _
"(BT)" & @CRLF & _
"(?<text>.*?)" & @CRLF & _
"(ET)"
Local $sString = "---" & @CRLF & _
"---" & @CRLF & _
"85.039 42.52 42.519 42.52 re" & @CRLF & _
"W--" & @CRLF & _
"---" & @CRLF & _
"---" & @CRLF & _
"127.559 42.52 42.519 42.52 re" & @CRLF & _
"W--" & @CRLF & _
"---" & @CRLF & _
"---" & @CRLF & _
"170.078 42.52 42.52 42.52 re" & @CRLF & _
"W--" & @CRLF & _
"---" & @CRLF & _
"---" & @CRLF & _
"BT" & @CRLF & _
"---" & @CRLF & _
"Text" & @CRLF & _
"---" & @CRLF & _
"ET" & @CRLF & _
"---" & @CRLF & _
"---" & @CRLF & _
"170.078 42.52 42.52 42.52 re" & @CRLF & _
"W--" & @CRLF & _
"---" & @CRLF & _
"---" & @CRLF & _
"127.559 42.52 42.519 42.52 re" & @CRLF & _
"W--" & @CRLF & _
"---" & @CRLF & _
"---" & @CRLF & _
"BT" & @CRLF & _
"---" & @CRLF & _
"Text" & @CRLF & _
"---" & @CRLF & _
"ET" & @CRLF & _
"---" & @CRLF & _
"---" & @CRLF & _
"170.078 42.52 42.52 42.52 re" & @CRLF & _
"W--" & @CRLF & _
"---" & @CRLF & _
"---" & @CRLF & _
"BT" & @CRLF & _
"---" & @CRLF & _
"Text" & @CRLF & _
"---" & @CRLF & _
"ET"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")