re = /(?<!`)\b\w+(?:\s+\w+)*\b(?!`)/
str = 'one `two three` four five `six` seven'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end