$re = '/^([\w.-]+)@([\w.-]+)(\.\w+)$/m';
$str = 'x@x.com
x.x@x.com
xx@xxx.com
x.x@xxx.com
x.x.x@xxx.com
x@x.x.x.com
x@x.x.com
na.va.waterloo@deal.rena.com
etc...
caps@avi.trav';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);