$re = '~/img/(([^/]+)(?i:\.jpe?g))$~m';
$str = '/home/my/siteblog
/home/my/siteblog/img/example.jpg
/home/my/siteblog/img/example.JPG
/home/my/siteblog/img/another-image.jpeg
/home/my/siteblog/img/stupid-extension.jpEG';
$subst = "/img-cleaned-up/$2.jpg?original=$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;