re = /^https?:\/\/(www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_\+.~#?&\/\/=]*)$/m
str = 'https://regex101.com
https://regex101.com/test
https://regex101.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end