$re = '/some_text_here(?=.*(?P<a>A))?(?=.*(?P<b>B))?(?=.*(?P<c>C))?/';
$str = 'some_text_here A B C
some_text_here A C B
some_text_here B C
some_text_here C ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);