package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^\[\]]+|\[(?1)\])$`)
var str = `[foo]
[[foo]]
[[foo]]]
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}