$re = '/”.*?”/';
$str = 'Nykyisin tietojen erotteluun tekstimassojen seasta, ns. tekstinlouhintaan (engl. text mining) on olemassa tehokkaita työkaluja. Tärkeimmät näistä ovat niin sanottuihin säännöllisiin lausekkeisiin tai tuttavallisemmin regexeihin perustuvat haut, missä termi ”regex” viittaa menetelmän englanninkieliseen vastineeseen regular expressions. Regexien juuret tekstinlouhinnassa juontavat viime vuosisadan puolivälin kieppeille. Regex-haut muistuttavat yksinkertaisimmillaan tavanomaista tekstin hakutoimintoa (voit testata selaimesi tekstihakua painamalla näppäimistössäsi CTRL+F ja kirjoittamalla ”jotain”). Regexien avulla tekstin seasta voi kuitenkin pyydystää myös hyvin monimutkaisia tekstikuvioita. Esimerkiksi komento ”Esim.*lauseen” poimisi tästä blogista ainoastaan tämän lauseen ( DEMO ), kun taas haku ””.*?”” löytäisi kaiken blogissa hipsukoiden sisässä esiintyvän sisällön ( DEMO ).';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);