import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[78]([0-9]{10})";
final String string = " '84951234567', '+74951234567', '8-495-1-234-567', \n"
+ " ' 8 (8122) 56-56-56', '8-911-1234567', '8 (911) 12 345 67', \n"
+ " '8-911 12 345 67', '8 (911) - 123 - 45 - 67', '+ 7 999 123 4567', \n"
+ " '8 ( 999 ) 1234567', '8 999 123 4567'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}