re = /^(?:[^\/](?:.*[^\/])?)?$/m
str = 'g
tt
/ttt
/sss/
arstarst/
asrasrt
arstarstsra/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end